Can't get s3curl to work

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Can't get s3curl to work

Amar Kapadia
Also posted on Launchpad. Sorry for posting to two places.
==
Hi All,

I installed the s3 API on my swift cluster.
I can successfully connect to it via Cyberduck and Python boto library. But not with s3curl. I can't figure out what I'm doing wrong. Help appreciated.
Error below:
====
akapadia at ubuntu:~/s3-curl$ ./s3curl.pl --id personal --head -- -k -v -s?https://ec2-184-73-4-50.compute-1.amazonaws.com
* About to connect() to ec2-184-73-4-50.compute-1.amazonaws.com port 443 (#0)
* Trying 10.113.35.108... connected
* Connected to ec2-184-73-4-50.compute-1.amazonaws.com (10.113.35.108) port 443 (#0)
* successfully set certificate verify locations:
* CAfile: none
??CApath: /etc/ssl/certs
* SSLv3, TLS handshake, Client hello (1):
* SSLv3, TLS handshake, Server hello (2):
* SSLv3, TLS handshake, CERT (11):
* SSLv3, TLS handshake, Server finished (14):
* SSLv3, TLS handshake, Client key exchange (16):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSLv3, TLS change cipher, Client hello (1):
* SSLv3, TLS handshake, Finished (20):
* SSL connection using AES256-SHA
* Server certificate:
* subject: C=US; ST=CA; L=San Jose; O=OpenStack Consulting; OU=Swift; CN=ec2-184-73-4-50.compute-1.amazonaws.com; emailAddress=bitnami at ec2-184-73-4-50.compute-1.amazonaws.com
* start date: 2011-11-04 04:26:58 GMT
* expire date: 2011-12-04 04:26:58 GMT
* common name: ec2-184-73-4-50.compute-1.amazonaws.com (matched)
* issuer: C=US; ST=CA; L=San Jose; O=OpenStack Consulting; OU=Swift; CN=ec2-184-73-4-50.compute-1.amazonaws.com; emailAddress=bitnami at ec2-184-73-4-50.compute-1.amazonaws.com
* SSL certificate verify result: self signed certificate (18), continuing anyway.
> HEAD / HTTP/1.1
> User-Agent: curl/7.19.7 (i486-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15
> Host: ec2-184-73-4-50.compute-1.amazonaws.com
> Accept: */*
> Date: Fri, 04 Nov 2011 04:40:41 +0000
> Authorization: AWS test:tester:shoi7Ubs/hYe2VGucf5YesElDMI=
>
< HTTP/1.1 400 Bad Request
HTTP/1.1 400 Bad Request
< Content-Type: text/xml; charset=UTF-8
Content-Type: text/xml; charset=UTF-8
< Content-Length: 142
Content-Length: 142
< Date: Fri, 04 Nov 2011 04:40:42 GMT
Date: Fri, 04 Nov 2011 04:40:42 GMT
<
* Connection #0 to host ec2-184-73-4-50.compute-1.amazonaws.com left intact
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20111103/575f71d8/attachment.html>