Starting images on test install

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Starting images on test install

Arjun Datta
Hi,
 
I am testing nova on a test server and have gotten the cloud controller
and compute node to install properly.  I have also setup a project and a
network.  all services are running correctly as far as I can tell:
 
# ps auwx | grep nova
nova      3695  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-compute --flagfile=/etc/nova/nova.conf nova
nova      3699  1.2  2.5 168868 52692 ?        S    Aug10  21:49
/usr/bin/python /usr/bin/nova-compute --flagfile=/etc/nova/nova.conf
nova      3705  0.0  0.0  35708  1280 ?        Ss   Aug10   0:00 su -c
nova-network --flagfile=/etc/nova/nova.conf nova
nova      3709  1.2  1.8 112224 38556 ?        S    Aug10  20:52
/usr/bin/python /usr/bin/nova-network --flagfile=/etc/nova/nova.conf
nova      3715  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-scheduler --flagfile=/etc/nova/nova.conf nova
nova      3719  1.2  1.8 112308 38632 ?        S    Aug10  20:42
/usr/bin/python /usr/bin/nova-scheduler --flagfile=/etc/nova/nova.conf
nova      3741  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-api --flagfile=/etc/nova/nova.conf nova
nova      3742  0.0  2.1 125068 44656 ?        S    Aug10   0:01
/usr/bin/python /usr/bin/nova-api --flagfile=/etc/nova/nova.conf
root      4219  0.0  0.7  61208 16128 ?        S    06:25   0:00
/usr/bin/python /usr/bin/nova-objectstore --uid 105 --gid 65534
--pidfile /var/run/nova/nova-objectstore.pid
--flagfile=/etc/nova/nova.conf --nodaemon
--logfile=/var/log/nova/nova-objectstore.log

Now,
 
I have downloaded an image and tried to start it as per the instructions
here:
http://docs.openstack.org/cactus/openstack-compute/admin/content/startin
g-images.html
 
But I get the following error:
# ls -l
total 364080
-rw-r--r-- 1 nova nova 372810310 2011-01-06 17:43
ubuntu1010-UEC-localuser-image.tar.gz

# uec-publish-tarball ubuntu-support-status novatest x86_64
bad tarball: ubuntu-support-status

I have changed the owenership of the image to nova:nova as well. Is
there some prerequisitie I am missing before starting this image ?
 
Regards,
 
Arjun Datta

 

--------------------------------------------------------------------------
?This electronic message contains information from Primus Telecommunications Canada Inc. ("PRIMUS") , which may be legally privileged and confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or e-mail (to the number or address above) immediately. Any views, opinions or advice expressed in this electronic message are not necessarily the views, opinions or advice of PRIMUS. It is the responsibility of the recipient to ensure that any attachments are virus free and PRIMUS bears no responsibility for any loss or damage arising in any way from the use thereof.The term "PRIMUS" includes its affiliates.
--------------------------------------------------------------------------
?Pour la version en fran?ais de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110811/44d936db/attachment.html>

Reply | Threaded
Open this post in threaded view
|

Starting images on test install

Arjun Datta
I think I see the problem, the file I am specifying to
uec-publish-tarball is incorrect.
 
I'll try again with the correct filename.
 
Regards,
 
Arjun Datta
 

________________________________

From: Arjun Datta
Sent: August-11-11 2:32 PM
To: 'openstack-operators at lists.openstack.org'
Subject: Starting images on test install


Hi,
 
I am testing nova on a test server and have gotten the cloud controller
and compute node to install properly.  I have also setup a project and a
network.  all services are running correctly as far as I can tell:
 
# ps auwx | grep nova
nova      3695  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-compute --flagfile=/etc/nova/nova.conf nova
nova      3699  1.2  2.5 168868 52692 ?        S    Aug10  21:49
/usr/bin/python /usr/bin/nova-compute --flagfile=/etc/nova/nova.conf
nova      3705  0.0  0.0  35708  1280 ?        Ss   Aug10   0:00 su -c
nova-network --flagfile=/etc/nova/nova.conf nova
nova      3709  1.2  1.8 112224 38556 ?        S    Aug10  20:52
/usr/bin/python /usr/bin/nova-network --flagfile=/etc/nova/nova.conf
nova      3715  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-scheduler --flagfile=/etc/nova/nova.conf nova
nova      3719  1.2  1.8 112308 38632 ?        S    Aug10  20:42
/usr/bin/python /usr/bin/nova-scheduler --flagfile=/etc/nova/nova.conf
nova      3741  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-api --flagfile=/etc/nova/nova.conf nova
nova      3742  0.0  2.1 125068 44656 ?        S    Aug10   0:01
/usr/bin/python /usr/bin/nova-api --flagfile=/etc/nova/nova.conf
root      4219  0.0  0.7  61208 16128 ?        S    06:25   0:00
/usr/bin/python /usr/bin/nova-objectstore --uid 105 --gid 65534
--pidfile /var/run/nova/nova-objectstore.pid
--flagfile=/etc/nova/nova.conf --nodaemon
--logfile=/var/log/nova/nova-objectstore.log

Now,
 
I have downloaded an image and tried to start it as per the instructions
here:
http://docs.openstack.org/cactus/openstack-compute/admin/content/startin
g-images.html
 
But I get the following error:
# ls -l
total 364080
-rw-r--r-- 1 nova nova 372810310 2011-01-06 17:43
ubuntu1010-UEC-localuser-image.tar.gz

# uec-publish-tarball ubuntu-support-status novatest x86_64
bad tarball: ubuntu-support-status

I have changed the owenership of the image to nova:nova as well. Is
there some prerequisitie I am missing before starting this image ?
 
Regards,
 
Arjun Datta

 

--------------------------------------------------------------------------
?This electronic message contains information from Primus Telecommunications Canada Inc. ("PRIMUS") , which may be legally privileged and confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or e-mail (to the number or address above) immediately. Any views, opinions or advice expressed in this electronic message are not necessarily the views, opinions or advice of PRIMUS. It is the responsibility of the recipient to ensure that any attachments are virus free and PRIMUS bears no responsibility for any loss or damage arising in any way from the use thereof.The term "PRIMUS" includes its affiliates.
--------------------------------------------------------------------------
?Pour la version en fran?ais de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110811/2d90e65a/attachment.html>

Reply | Threaded
Open this post in threaded view
|

Starting images on test install

Arjun Datta
Okay, this time I got further:
 
# uec-publish-tarball ubuntu1010-UEC-localuser-image.tar.gz novatest
x86_64
Thu Aug 11 15:57:24 EDT 2011: ====== extracting image ======
Warning: no ramdisk found, assuming '--ramdisk none'
kernel : maverick-server-uec-amd64-vmlinuz-virtual
ramdisk: none
image  : maverick-server-uec-amd64.img
Thu Aug 11 16:02:21 EDT 2011: ====== bundle/upload kernel ======
failed to bundle kernel maverick-server-uec-amd64-vmlinuz-virtual
failed: euca-bundle-image --destination /tmp/uec-publish-image.z94Byl
--arch i386 --image
/tmp/uec-publish-image.z94Byl/.rename.tFCeei/maverick-server-uec-amd64-v
mlinuz-virtual --kernel true
i386
Invalid certfailed to upload kernel

So, I'm assuming something is missing in my /root/creds or .~/bashrc
 
The latter contains the following at the end:
 
NOVA_KEY_DIR=$(pushd $(dirname $BASH_SOURCE)>/dev/null; pwd;
popd>/dev/null)
export EC2_ACCESS_KEY="46278fbb-0376-47da-be5b-11c263f321a4:novatest"
export EC2_SECRET_KEY="65a92814-766a-49f7-98d5-1c68c48b867a"
export EC2_URL="http://192.168.140.15:8773/services/Cloud
<http://192.168.140.15:8773/services/Cloud> "
export S3_URL="http://192.168.140.15:3333 <http://192.168.140.15:3333> "
export EC2_USER_ID=42 # nova does not use user id, but bundling requires
it
export EC2_PRIVATE_KEY=${NOVA_KEY_DIR}/pk.pem
export EC2_CERT=${NOVA_KEY_DIR}/cert.pem
export NOVA_CERT=${NOVA_KEY_DIR}/cacert.pem
export EUCALYPTUS_CERT=${NOVA_CERT} # euca-bundle-image seems to require
this set
alias ec2-bundle-image="ec2-bundle-image --cert ${EC2_CERT} --privatekey
${EC2_PRIVATE_KEY} --user 42 --ec2cert ${NOVA_CERT}"
alias ec2-upload-bundle="ec2-upload-bundle -a ${EC2_ACCESS_KEY} -s
${EC2_SECRET_KEY} --url ${S3_URL} --ec2cert ${NOVA_CERT}"
export NOVA_API_KEY="46278fbb-0376-47da-be5b-11c263f321a4"
export NOVA_USERNAME="novatest"
export NOVA_URL="http://192.168.140.15:8774/v1.0/
<http://192.168.140.15:8774/v1.0/> "

Is there any other cert I need to install ?
 
 
Regards,
 
Arjun Datta
 


________________________________

From: Arjun Datta
Sent: August-11-11 3:20 PM
To: Arjun Datta; 'openstack-operators at lists.openstack.org'
Subject: RE: Starting images on test install


I think I see the problem, the file I am specifying to
uec-publish-tarball is incorrect.
 
I'll try again with the correct filename.
 
Regards,
 
Arjun Datta
 

________________________________

From: Arjun Datta
Sent: August-11-11 2:32 PM
To: 'openstack-operators at lists.openstack.org'
Subject: Starting images on test install


Hi,
 
I am testing nova on a test server and have gotten the cloud controller
and compute node to install properly.  I have also setup a project and a
network.  all services are running correctly as far as I can tell:
 
# ps auwx | grep nova
nova      3695  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-compute --flagfile=/etc/nova/nova.conf nova
nova      3699  1.2  2.5 168868 52692 ?        S    Aug10  21:49
/usr/bin/python /usr/bin/nova-compute --flagfile=/etc/nova/nova.conf
nova      3705  0.0  0.0  35708  1280 ?        Ss   Aug10   0:00 su -c
nova-network --flagfile=/etc/nova/nova.conf nova
nova      3709  1.2  1.8 112224 38556 ?        S    Aug10  20:52
/usr/bin/python /usr/bin/nova-network --flagfile=/etc/nova/nova.conf
nova      3715  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-scheduler --flagfile=/etc/nova/nova.conf nova
nova      3719  1.2  1.8 112308 38632 ?        S    Aug10  20:42
/usr/bin/python /usr/bin/nova-scheduler --flagfile=/etc/nova/nova.conf
nova      3741  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-api --flagfile=/etc/nova/nova.conf nova
nova      3742  0.0  2.1 125068 44656 ?        S    Aug10   0:01
/usr/bin/python /usr/bin/nova-api --flagfile=/etc/nova/nova.conf
root      4219  0.0  0.7  61208 16128 ?        S    06:25   0:00
/usr/bin/python /usr/bin/nova-objectstore --uid 105 --gid 65534
--pidfile /var/run/nova/nova-objectstore.pid
--flagfile=/etc/nova/nova.conf --nodaemon
--logfile=/var/log/nova/nova-objectstore.log

Now,
 
I have downloaded an image and tried to start it as per the instructions
here:
http://docs.openstack.org/cactus/openstack-compute/admin/content/startin
g-images.html
 
But I get the following error:
# ls -l
total 364080
-rw-r--r-- 1 nova nova 372810310 2011-01-06 17:43
ubuntu1010-UEC-localuser-image.tar.gz

# uec-publish-tarball ubuntu-support-status novatest x86_64
bad tarball: ubuntu-support-status

I have changed the owenership of the image to nova:nova as well. Is
there some prerequisitie I am missing before starting this image ?
 
Regards,
 
Arjun Datta

 

--------------------------------------------------------------------------
?This electronic message contains information from Primus Telecommunications Canada Inc. ("PRIMUS") , which may be legally privileged and confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or e-mail (to the number or address above) immediately. Any views, opinions or advice expressed in this electronic message are not necessarily the views, opinions or advice of PRIMUS. It is the responsibility of the recipient to ensure that any attachments are virus free and PRIMUS bears no responsibility for any loss or damage arising in any way from the use thereof.The term "PRIMUS" includes its affiliates.
--------------------------------------------------------------------------
?Pour la version en fran?ais de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110811/8978bd16/attachment-0001.html>

Reply | Threaded
Open this post in threaded view
|

Starting images on test install

Arjun Datta
I fixed it this time by querying the NOVA_KEY_DIR value which was /root.
My keys were in /root/creds and so simply moving them into /root fixed
the problem.  the test image has been published it appears:
 
 
 
# uec-publish-tarball ubuntu1010-UEC-localuser-image.tar.gz novatest
x86_64
Thu Aug 11 16:10:19 EDT 2011: ====== extracting image ======
Warning: no ramdisk found, assuming '--ramdisk none'
kernel : maverick-server-uec-amd64-vmlinuz-virtual
ramdisk: none
image  : maverick-server-uec-amd64.img
Thu Aug 11 16:15:15 EDT 2011: ====== bundle/upload kernel ======
Thu Aug 11 16:15:30 EDT 2011: ====== bundle/upload image ======
Thu Aug 11 16:28:32 EDT 2011: ====== done ======
emi="ami-15bd14eb"; eri="none"; eki="aki-331091d0";

 
 
 
For future reference, is there a recommended location to store the keys
and the images ?
 
 
 
Regards,
 
Arjun Datta
 

________________________________

From: Arjun Datta
Sent: August-11-11 4:06 PM
To: Arjun Datta; 'openstack-operators at lists.openstack.org'
Subject: RE: Starting images on test install


Okay, this time I got further:
 
# uec-publish-tarball ubuntu1010-UEC-localuser-image.tar.gz novatest
x86_64
Thu Aug 11 15:57:24 EDT 2011: ====== extracting image ======
Warning: no ramdisk found, assuming '--ramdisk none'
kernel : maverick-server-uec-amd64-vmlinuz-virtual
ramdisk: none
image  : maverick-server-uec-amd64.img
Thu Aug 11 16:02:21 EDT 2011: ====== bundle/upload kernel ======
failed to bundle kernel maverick-server-uec-amd64-vmlinuz-virtual
failed: euca-bundle-image --destination /tmp/uec-publish-image.z94Byl
--arch i386 --image
/tmp/uec-publish-image.z94Byl/.rename.tFCeei/maverick-server-uec-amd64-v
mlinuz-virtual --kernel true
i386
Invalid certfailed to upload kernel

So, I'm assuming something is missing in my /root/creds or .~/bashrc
 
The latter contains the following at the end:
 
NOVA_KEY_DIR=$(pushd $(dirname $BASH_SOURCE)>/dev/null; pwd;
popd>/dev/null)
export EC2_ACCESS_KEY="46278fbb-0376-47da-be5b-11c263f321a4:novatest"
export EC2_SECRET_KEY="65a92814-766a-49f7-98d5-1c68c48b867a"
export EC2_URL="http://192.168.140.15:8773/services/Cloud
<http://192.168.140.15:8773/services/Cloud> "
export S3_URL="http://192.168.140.15:3333 <http://192.168.140.15:3333> "
export EC2_USER_ID=42 # nova does not use user id, but bundling requires
it
export EC2_PRIVATE_KEY=${NOVA_KEY_DIR}/pk.pem
export EC2_CERT=${NOVA_KEY_DIR}/cert.pem
export NOVA_CERT=${NOVA_KEY_DIR}/cacert.pem
export EUCALYPTUS_CERT=${NOVA_CERT} # euca-bundle-image seems to require
this set
alias ec2-bundle-image="ec2-bundle-image --cert ${EC2_CERT} --privatekey
${EC2_PRIVATE_KEY} --user 42 --ec2cert ${NOVA_CERT}"
alias ec2-upload-bundle="ec2-upload-bundle -a ${EC2_ACCESS_KEY} -s
${EC2_SECRET_KEY} --url ${S3_URL} --ec2cert ${NOVA_CERT}"
export NOVA_API_KEY="46278fbb-0376-47da-be5b-11c263f321a4"
export NOVA_USERNAME="novatest"
export NOVA_URL="http://192.168.140.15:8774/v1.0/
<http://192.168.140.15:8774/v1.0/> "

Is there any other cert I need to install ?
 
 
Regards,
 
Arjun Datta
 


________________________________

From: Arjun Datta
Sent: August-11-11 3:20 PM
To: Arjun Datta; 'openstack-operators at lists.openstack.org'
Subject: RE: Starting images on test install


I think I see the problem, the file I am specifying to
uec-publish-tarball is incorrect.
 
I'll try again with the correct filename.
 
Regards,
 
Arjun Datta
 

________________________________

From: Arjun Datta
Sent: August-11-11 2:32 PM
To: 'openstack-operators at lists.openstack.org'
Subject: Starting images on test install


Hi,
 
I am testing nova on a test server and have gotten the cloud controller
and compute node to install properly.  I have also setup a project and a
network.  all services are running correctly as far as I can tell:
 
# ps auwx | grep nova
nova      3695  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-compute --flagfile=/etc/nova/nova.conf nova
nova      3699  1.2  2.5 168868 52692 ?        S    Aug10  21:49
/usr/bin/python /usr/bin/nova-compute --flagfile=/etc/nova/nova.conf
nova      3705  0.0  0.0  35708  1280 ?        Ss   Aug10   0:00 su -c
nova-network --flagfile=/etc/nova/nova.conf nova
nova      3709  1.2  1.8 112224 38556 ?        S    Aug10  20:52
/usr/bin/python /usr/bin/nova-network --flagfile=/etc/nova/nova.conf
nova      3715  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-scheduler --flagfile=/etc/nova/nova.conf nova
nova      3719  1.2  1.8 112308 38632 ?        S    Aug10  20:42
/usr/bin/python /usr/bin/nova-scheduler --flagfile=/etc/nova/nova.conf
nova      3741  0.0  0.0  35708  1276 ?        Ss   Aug10   0:00 su -c
nova-api --flagfile=/etc/nova/nova.conf nova
nova      3742  0.0  2.1 125068 44656 ?        S    Aug10   0:01
/usr/bin/python /usr/bin/nova-api --flagfile=/etc/nova/nova.conf
root      4219  0.0  0.7  61208 16128 ?        S    06:25   0:00
/usr/bin/python /usr/bin/nova-objectstore --uid 105 --gid 65534
--pidfile /var/run/nova/nova-objectstore.pid
--flagfile=/etc/nova/nova.conf --nodaemon
--logfile=/var/log/nova/nova-objectstore.log

Now,
 
I have downloaded an image and tried to start it as per the instructions
here:
http://docs.openstack.org/cactus/openstack-compute/admin/content/startin
g-images.html
 
But I get the following error:
# ls -l
total 364080
-rw-r--r-- 1 nova nova 372810310 2011-01-06 17:43
ubuntu1010-UEC-localuser-image.tar.gz

# uec-publish-tarball ubuntu-support-status novatest x86_64
bad tarball: ubuntu-support-status

I have changed the owenership of the image to nova:nova as well. Is
there some prerequisitie I am missing before starting this image ?
 
Regards,
 
Arjun Datta

 

--------------------------------------------------------------------------
?This electronic message contains information from Primus Telecommunications Canada Inc. ("PRIMUS") , which may be legally privileged and confidential. The information is intended to be for the use of the individual(s) or entity named above. If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited. If you have received this electronic message in error, please notify us by telephone or e-mail (to the number or address above) immediately. Any views, opinions or advice expressed in this electronic message are not necessarily the views, opinions or advice of PRIMUS. It is the responsibility of the recipient to ensure that any attachments are virus free and PRIMUS bears no responsibility for any loss or damage arising in any way from the use thereof.The term "PRIMUS" includes its affiliates.
--------------------------------------------------------------------------
?Pour la version en fran?ais de ce message, veuillez voir
http://www.primustel.ca/fr/legal/cs.htm
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110811/cb92dff9/attachment.html>