[kuryr] kuryr libnetwork installation inside the vm is failing

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[kuryr] kuryr libnetwork installation inside the vm is failing

Vikrant Aggarwal

Started one Fedora 29 VM on openstack using official qcow2 image.

I followed this doc for kuryr installation inside the VM.

https://docs.openstack.org/kuryr-libnetwork/latest/readme.html

My objective is to run the nested docker i.e inside the VM.

While installing the kuryr-libbetwork from the source. it's getting failed with following error:

~~~
[root@vm0 kuryr-libnetwork]# pip install .
WARNING: Running pip install with root privileges is generally not a good idea. Try `pip install --user` instead.
Processing /root/kuryr-libnetwork
Requirement already satisfied: Babel!=2.4.0,>=2.3.4 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (2.6.0)
Requirement already satisfied: Flask!=0.11,>=0.10 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (1.0.2)
Requirement already satisfied: ipaddress>=1.0.17 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (1.0.22)
Requirement already satisfied: jsonschema<3.0.0,>=2.6.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (2.6.0)
Collecting kuryr-lib>=0.5.0 (from kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/19/f0/8a425cb4a34ce641e32c5bba3cddc19abf1cd7034537ec7acb9c96ec305d/kuryr_lib-0.8.0-py2.py3-none-any.whl
Requirement already satisfied: neutron-lib>=1.13.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (1.20.0)
Collecting os-client-config>=1.28.0 (from kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/e5/af/2f3bf859a25c98993f85ff1eb17762aa49b2f894630ebe99c389545b0502/os_client_config-1.31.2-py2.py3-none-any.whl
Requirement already satisfied: oslo.concurrency>=3.25.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (3.29.0)
Requirement already satisfied: oslo.config>=5.2.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (6.7.0)
Requirement already satisfied: oslo.log>=3.36.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (3.41.0)
Requirement already satisfied: oslo.utils>=3.33.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (3.37.1)
Requirement already satisfied: pbr!=2.1.0,>=2.0.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (5.1.1)
Collecting python-neutronclient>=6.7.0 (from kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/cd/40/2fee7f7f2b562f987c59dfa499ed084af44b57e3c7e342ed2fa5b41d73aa/python_neutronclient-6.11.0-py2.py3-none-any.whl
Requirement already satisfied: six>=1.10.0 in /usr/lib/python2.7/site-packages (from kuryr-libnetwork==2.0.1.dev20) (1.11.0)
Requirement already satisfied: pytz>=0a in /usr/lib/python2.7/site-packages (from Babel!=2.4.0,>=2.3.4->kuryr-libnetwork==2.0.1.dev20) (2018.7)
Requirement already satisfied: Werkzeug>=0.14 in /usr/lib/python2.7/site-packages (from Flask!=0.11,>=0.10->kuryr-libnetwork==2.0.1.dev20) (0.14.1)
Requirement already satisfied: click>=5.1 in /usr/lib64/python2.7/site-packages (from Flask!=0.11,>=0.10->kuryr-libnetwork==2.0.1.dev20) (7.0)
Requirement already satisfied: itsdangerous>=0.24 in /usr/lib/python2.7/site-packages (from Flask!=0.11,>=0.10->kuryr-libnetwork==2.0.1.dev20) (1.1.0)
Requirement already satisfied: Jinja2>=2.10 in /usr/lib/python2.7/site-packages (from Flask!=0.11,>=0.10->kuryr-libnetwork==2.0.1.dev20) (2.10)
Requirement already satisfied: functools32; python_version == "2.7" in /usr/lib/python2.7/site-packages (from jsonschema<3.0.0,>=2.6.0->kuryr-libnetwork==2.0.1.dev20) (3.2.3.post2)
Requirement already satisfied: keystoneauth1>=3.4.0 in /usr/lib/python2.7/site-packages (from kuryr-lib>=0.5.0->kuryr-libnetwork==2.0.1.dev20) (3.11.1)
Requirement already satisfied: oslo.i18n>=3.15.3 in /usr/lib/python2.7/site-packages (from kuryr-lib>=0.5.0->kuryr-libnetwork==2.0.1.dev20) (3.23.0)
Requirement already satisfied: pyroute2>=0.4.21; sys_platform != "win32" in /usr/lib/python2.7/site-packages (from kuryr-lib>=0.5.0->kuryr-libnetwork==2.0.1.dev20) (0.5.3)
Requirement already satisfied: SQLAlchemy!=1.1.5,!=1.1.6,!=1.1.7,!=1.1.8,>=1.0.10 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.2.14)
Requirement already satisfied: osprofiler>=1.4.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.5.1)
Requirement already satisfied: oslo.versionedobjects>=1.31.2 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.34.1)
Requirement already satisfied: oslo.context>=2.19.2 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.21.0)
Requirement already satisfied: oslo.policy>=1.30.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.41.1)
Requirement already satisfied: oslo.db>=4.27.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (4.42.0)
Requirement already satisfied: os-traits>=0.9.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.10.0)
Requirement already satisfied: oslo.serialization!=2.19.1,>=2.18.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.28.1)
Requirement already satisfied: oslo.service!=1.28.1,>=1.24.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.33.0)
Requirement already satisfied: WebOb>=1.7.1 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.8.4)
Requirement already satisfied: oslo.messaging>=5.29.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (9.2.1)
Requirement already satisfied: stevedore>=1.20.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.30.0)
Requirement already satisfied: weakrefmethod>=1.0.2; python_version == "2.7" in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.3)
Requirement already satisfied: pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0 in /usr/lib/python2.7/site-packages (from neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.3.2)
Collecting openstacksdk>=0.13.0 (from os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/05/e1/38b3fe8b3fa8b78c8917bc78e2aa3f1a13312bc810ee83d5d8f285514245/openstacksdk-0.19.0-py2.py3-none-any.whl
Requirement already satisfied: enum34>=1.0.4; python_version == "2.7" or python_version == "2.6" or python_version == "3.3" in /usr/lib/python2.7/site-packages (from oslo.concurrency>=3.25.0->kuryr-libnetwork==2.0.1.dev20) (1.1.6)
Requirement already satisfied: fasteners>=0.7.0 in /usr/lib/python2.7/site-packages (from oslo.concurrency>=3.25.0->kuryr-libnetwork==2.0.1.dev20) (0.14.1)
Requirement already satisfied: rfc3986>=0.3.1 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (1.1.0)
Requirement already satisfied: netaddr>=0.7.18 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (0.7.19)
Requirement already satisfied: PyYAML>=3.12 in /usr/lib64/python2.7/site-packages (from oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (3.13)
Requirement already satisfied: requests>=2.18.0 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (2.20.1)
Requirement already satisfied: debtcollector>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (1.20.0)
Requirement already satisfied: monotonic>=1.4 in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->kuryr-libnetwork==2.0.1.dev20) (1.5)
Requirement already satisfied: python-dateutil>=2.7.0 in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->kuryr-libnetwork==2.0.1.dev20) (2.7.5)
Requirement already satisfied: pyinotify>=0.9.6; sys_platform != "win32" and sys_platform != "darwin" and sys_platform != "sunos5" in /usr/lib/python2.7/site-packages (from oslo.log>=3.36.0->kuryr-libnetwork==2.0.1.dev20) (0.9.6)
Requirement already satisfied: netifaces>=0.10.4 in /usr/lib64/python2.7/site-packages (from oslo.utils>=3.33.0->kuryr-libnetwork==2.0.1.dev20) (0.10.7)
Requirement already satisfied: pyparsing>=2.1.0 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->kuryr-libnetwork==2.0.1.dev20) (2.3.0)
Requirement already satisfied: funcsigs>=1.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->kuryr-libnetwork==2.0.1.dev20) (1.0.2)
Requirement already satisfied: iso8601>=0.1.11 in /usr/lib/python2.7/site-packages (from oslo.utils>=3.33.0->kuryr-libnetwork==2.0.1.dev20) (0.1.12)
Collecting osc-lib>=1.8.0 (from python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/8d/a8/b63a53baed828a3e46ff2d1ee5cb63f794e9e071f05e99229642edfc46a5/osc-lib-1.11.1.tar.gz
Collecting python-keystoneclient>=3.8.0 (from python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/51/48/c25bb60d7b95294cc5e49a406ae0b9e10f3e0ff533d0df149501abf70300/python_keystoneclient-3.18.0-py2.py3-none-any.whl
Collecting cliff!=2.9.0,>=2.8.0 (from python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/8e/1a/5404afee3d83a2e5f27e0d20ac7012c9f07bd8e9b03d0ae1fd9bb3e63037/cliff-2.14.0-py2.py3-none-any.whl
Collecting simplejson>=3.5.1 (from python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/e3/24/c35fb1c1c315fc0fffe61ea00d3f88e85469004713dab488dee4f35b0aff/simplejson-3.16.0.tar.gz
Requirement already satisfied: MarkupSafe>=0.23 in /usr/lib64/python2.7/site-packages (from Jinja2>=2.10->Flask!=0.11,>=0.10->kuryr-libnetwork==2.0.1.dev20) (1.1.0)
Requirement already satisfied: os-service-types>=1.2.0 in /usr/lib/python2.7/site-packages (from keystoneauth1>=3.4.0->kuryr-lib>=0.5.0->kuryr-libnetwork==2.0.1.dev20) (1.3.0)
Requirement already satisfied: PrettyTable<0.8,>=0.7.2 in /usr/lib/python2.7/site-packages (from osprofiler>=1.4.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.7.2)
Requirement already satisfied: testscenarios>=0.4 in /usr/lib/python2.7/site-packages (from oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.5.0)
Requirement already satisfied: alembic>=0.9.6 in /usr/lib/python2.7/site-packages (from oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.5)
Requirement already satisfied: testresources>=2.0.0 in /usr/lib/python2.7/site-packages (from oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.0.1)
Requirement already satisfied: sqlalchemy-migrate>=0.11.0 in /usr/lib/python2.7/site-packages (from oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.11.0)
Requirement already satisfied: msgpack>=0.5.2 in /usr/lib64/python2.7/site-packages (from oslo.serialization!=2.19.1,>=2.18.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.5.6)
Requirement already satisfied: Paste>=2.0.2 in /usr/lib/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.0.4)
Requirement already satisfied: PasteDeploy>=1.5.0 in /usr/lib/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.5.2)
Requirement already satisfied: greenlet>=0.4.10 in /usr/lib64/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.4.15)
Requirement already satisfied: Routes>=2.3.1 in /usr/lib/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.4.1)
Requirement already satisfied: fixtures>=3.0.0 in /usr/lib/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.0.0)
Requirement already satisfied: eventlet!=0.18.3,!=0.20.1,>=0.18.2 in /usr/lib/python2.7/site-packages (from oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.24.1)
Requirement already satisfied: kombu!=4.0.2,>=4.0.0 in /usr/lib/python2.7/site-packages (from oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (4.2.1)
Requirement already satisfied: oslo.middleware>=3.31.0 in /usr/lib/python2.7/site-packages (from oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.36.0)
Requirement already satisfied: cachetools>=2.0.0 in /usr/lib/python2.7/site-packages (from oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.0.0)
Requirement already satisfied: futurist>=1.2.0 in /usr/lib/python2.7/site-packages (from oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.8.0)
Requirement already satisfied: amqp>=2.3.0 in /usr/lib/python2.7/site-packages (from oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.3.2)
Requirement already satisfied: logutils>=0.3 in /usr/lib/python2.7/site-packages (from pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.3.5)
Requirement already satisfied: singledispatch in /usr/lib/python2.7/site-packages (from pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.4.0.3)
Requirement already satisfied: Mako>=0.4.0 in /usr/lib/python2.7/site-packages (from pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.7)
Requirement already satisfied: WebTest>=1.3.1 in /usr/lib/python2.7/site-packages (from pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.0.32)
Collecting dogpile.cache>=0.6.2 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/73/bf/0cbed594e4f0f9360bfb98e7276131bf32e1af1d15e6c11a9dd8bd93a12f/dogpile.cache-0.6.8.tar.gz
Requirement already satisfied: decorator>=3.4.0 in /usr/lib/python2.7/site-packages (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20) (4.3.0)
Requirement already satisfied: futures>=3.0.0; python_version == "2.7" or python_version == "2.6" in /usr/lib/python2.7/site-packages (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20) (3.2.0)
Collecting requestsexceptions>=1.2.0 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/01/8c/49ca60ea8c907260da4662582c434bec98716177674e88df3fd340acf06d/requestsexceptions-1.4.0-py2.py3-none-any.whl
Collecting cryptography>=2.1 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/7f/ba/383b51cc26e3141c689ce988814385c7659f5ba01c4b5f2de38233010b5f/cryptography-2.4.2-cp27-cp27mu-manylinux1_x86_64.whl
Collecting munch>=2.1.0 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/68/f4/260ec98ea840757a0da09e0ed8135333d59b8dfebe9752a365b04857660a/munch-2.3.2.tar.gz
Collecting appdirs>=1.3.0 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/56/eb/810e700ed1349edde4cbdc1b2a21e28cdf115f9faf263f6bbf8447c1abf3/appdirs-1.4.3-py2.py3-none-any.whl
Collecting jsonpatch!=1.20,>=1.16 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/a0/e6/d50d526ae2218b765ddbdb2dda14d65e19f501ce07410b375bc43ad20b7a/jsonpatch-1.23-py2.py3-none-any.whl
Collecting jmespath>=0.9.0 (from openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/b7/31/05c8d001f7f87f0f07289a5fc0fc3832e9a57f2dbd4d3b0fee70e0d51365/jmespath-0.9.3-py2.py3-none-any.whl
Requirement already satisfied: idna<2.8,>=2.5 in /usr/lib/python2.7/site-packages (from requests>=2.18.0->oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (2.7)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests>=2.18.0->oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (3.0.4)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=2.18.0->oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (1.24.1)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.18.0->oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (2018.10.15)
Requirement already satisfied: wrapt>=1.7.0 in /usr/lib/python2.7/site-packages (from debtcollector>=1.2.0->oslo.config>=5.2.0->kuryr-libnetwork==2.0.1.dev20) (1.10.11)
Collecting cmd2!=0.8.3,<0.9.0; python_version < "3.0" (from cliff!=2.9.0,>=2.8.0->python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/e9/40/a71caa2aaff10c73612a7106e2d35f693e85b8cf6e37ab0774274bca3cf9/cmd2-0.8.9-py2.py3-none-any.whl
Collecting unicodecsv>=0.8.0; python_version < "3.0" (from cliff!=2.9.0,>=2.8.0->python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/6f/a4/691ab63b17505a26096608cc309960b5a6bdf39e4ba1a793d5f9b1a53270/unicodecsv-0.14.1.tar.gz
Requirement already satisfied: testtools in /usr/lib/python2.7/site-packages (from testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (2.3.0)
Requirement already satisfied: python-editor>=0.3 in /usr/lib/python2.7/site-packages (from alembic>=0.9.6->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.3)
Requirement already satisfied: sqlparse in /usr/lib/python2.7/site-packages (from sqlalchemy-migrate>=0.11.0->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.2.4)
Requirement already satisfied: Tempita>=0.4 in /usr/lib/python2.7/site-packages (from sqlalchemy-migrate>=0.11.0->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.5.2)
Requirement already satisfied: repoze.lru>=0.3 in /usr/lib/python2.7/site-packages (from Routes>=2.3.1->oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.7)
Requirement already satisfied: dnspython>=1.15.0 in /usr/lib/python2.7/site-packages (from eventlet!=0.18.3,!=0.20.1,>=0.18.2->oslo.service!=1.28.1,>=1.24.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.15.0)
Requirement already satisfied: statsd>=3.2.1 in /usr/lib/python2.7/site-packages (from oslo.middleware>=3.31.0->oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (3.3.0)
Requirement already satisfied: contextlib2>=0.4.0; python_version < "3.0" in /usr/lib/python2.7/site-packages (from futurist>=1.2.0->oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (0.5.5)
Requirement already satisfied: vine>=1.1.3 in /usr/lib/python2.7/site-packages (from amqp>=2.3.0->oslo.messaging>=5.29.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.1.4)
Requirement already satisfied: beautifulsoup4 in /usr/lib/python2.7/site-packages (from WebTest>=1.3.1->pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (4.6.3)
Requirement already satisfied: waitress>=0.8.5 in /usr/lib/python2.7/site-packages (from WebTest>=1.3.1->pecan!=1.0.2,!=1.0.3,!=1.0.4,!=1.2,>=1.0.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.1.0)
Collecting cffi!=1.11.3,>=1.7 (from cryptography>=2.1->openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/14/dd/3e7a1e1280e7d767bd3fa15791759c91ec19058ebe31217fe66f3e9a8c49/cffi-1.11.5-cp27-cp27mu-manylinux1_x86_64.whl
Collecting asn1crypto>=0.21.0 (from cryptography>=2.1->openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/ea/cd/35485615f45f30a510576f1a56d1e0a7ad7bd8ab5ed7cdc600ef7cd06222/asn1crypto-0.24.0-py2.py3-none-any.whl
Collecting jsonpointer>=1.9 (from jsonpatch!=1.20,>=1.16->openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/18/b0/a80d29577c08eea401659254dfaed87f1af45272899e1812d7e01b679bc5/jsonpointer-2.0-py2.py3-none-any.whl
Requirement already satisfied: pyperclip in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0; python_version < "3.0"->cliff!=2.9.0,>=2.8.0->python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20) (1.7.0)
Requirement already satisfied: wcwidth; sys_platform != "win32" in /usr/lib/python2.7/site-packages (from cmd2!=0.8.3,<0.9.0; python_version < "3.0"->cliff!=2.9.0,>=2.8.0->python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20) (0.1.7)
Collecting subprocess32; python_version < "3.0" (from cmd2!=0.8.3,<0.9.0; python_version < "3.0"->cliff!=2.9.0,>=2.8.0->python-neutronclient>=6.7.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/be/2b/beeba583e9877e64db10b52a96915afc0feabf7144dcbf2a0d0ea68bf73d/subprocess32-3.5.3.tar.gz
Requirement already satisfied: extras>=1.0.0 in /usr/lib/python2.7/site-packages (from testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.0)
Requirement already satisfied: unittest2>=1.0.0 in /usr/lib/python2.7/site-packages (from testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.1.0)
Requirement already satisfied: traceback2 in /usr/lib/python2.7/site-packages (from testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.4.0)
Requirement already satisfied: python-mimeparse in /usr/lib/python2.7/site-packages (from testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.6.0)
Collecting pycparser (from cffi!=1.11.3,>=1.7->cryptography>=2.1->openstacksdk>=0.13.0->os-client-config>=1.28.0->kuryr-libnetwork==2.0.1.dev20)
  Using cached https://files.pythonhosted.org/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz
Requirement already satisfied: argparse in /usr/lib/python2.7/site-packages (from unittest2>=1.0.0->testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.4.0)
Requirement already satisfied: linecache2 in /usr/lib/python2.7/site-packages (from traceback2->testtools->testscenarios>=0.4->oslo.db>=4.27.0->neutron-lib>=1.13.0->kuryr-libnetwork==2.0.1.dev20) (1.0.0)
Installing collected packages: subprocess32, cmd2, unicodecsv, cliff, dogpile.cache, requestsexceptions, pycparser, cffi, asn1crypto, cryptography, munch, appdirs, jsonpointer, jsonpatch, jmespath, openstacksdk, simplejson, osc-lib, python-keystoneclient, os-client-config, python-neutronclient, kuryr-lib, kuryr-libnetwork
  Running setup.py install for subprocess32 ... error
    Complete output from command /usr/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-tVH19b/subprocess32/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-_SN4DI/install-record.txt --single-version-externally-managed --compile:
    running install
    running build
    running build_py
    creating build
    creating build/lib.linux-x86_64-2.7
    copying subprocess32.py -> build/lib.linux-x86_64-2.7
    running build_ext
    running build_configure
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: in `/tmp/pip-install-tVH19b/subprocess32':
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-tVH19b/subprocess32/setup.py", line 120, in <module>
        main()
      File "/tmp/pip-install-tVH19b/subprocess32/setup.py", line 114, in main
        'Programming Language :: Python :: Implementation :: CPython',
      File "/usr/lib/python2.7/site-packages/setuptools/__init__.py", line 140, in setup
        return distutils.core.setup(**attrs)
      File "/usr/lib64/python2.7/distutils/core.py", line 151, in setup
        dist.run_commands()
      File "/usr/lib64/python2.7/distutils/dist.py", line 953, in run_commands
        self.run_command(cmd)
      File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/usr/lib/python2.7/site-packages/setuptools/command/install.py", line 61, in run
        return orig.install.run(self)
      File "/usr/lib64/python2.7/distutils/command/install.py", line 563, in run
        self.run_command('build')
      File "/usr/lib64/python2.7/distutils/cmd.py", line 326, in run_command
        self.distribution.run_command(command)
      File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/usr/lib64/python2.7/distutils/command/build.py", line 127, in run
        self.run_command(cmd_name)
      File "/usr/lib64/python2.7/distutils/cmd.py", line 326, in run_command
        self.distribution.run_command(command)
      File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/tmp/pip-install-tVH19b/subprocess32/setup.py", line 41, in run
        self.run_command(command)
      File "/usr/lib64/python2.7/distutils/cmd.py", line 326, in run_command
        self.distribution.run_command(command)
      File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
        cmd_obj.run()
      File "/tmp/pip-install-tVH19b/subprocess32/setup.py", line 26, in run
        raise RuntimeError(configure_command + ' failed.')
    RuntimeError: sh ./configure failed.

    ----------------------------------------
Command "/usr/bin/python2 -u -c "import setuptools, tokenize;__file__='/tmp/pip-install-tVH19b/subprocess32/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-record-_SN4DI/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-install-tVH19b/subprocess32/
~~~

python-dev and docker is already installed on the machine.


Any help is highly appreciated.

Thanks & Regards,
Vikrant Aggarwal

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev