[new][puppet] puppet-watcher 10.0.0 release (ocata)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[new][puppet] puppet-watcher 10.0.0 release (ocata)

no-reply
We are jubilant to announce the release of:

puppet-watcher 10.0.0: Puppet module for OpenStack Watcher

This is the first release of puppet-watcher. This release is part of
the ocata release series.

Download the package from:

    https://tarballs.openstack.org/puppet-watcher/

For more details, please see below.

Changes in puppet-watcher 23f5e1c6b11f50ed6bfa9e4cd19c67c7a907e072..10.0.0
--------------------------------------------------------------------------

660e151 Prepare 10.0.0 release
7759571 Fix centos7 ci
7a50b81 Added new parameters only for watcher sections.
6c96cc7 Add requirements in metadata.json file
c4652a3 Remove duplicate test items
c3cdcfe Add test for policy
edb8561 Add support for db_max_retries param
a9d1fcc Add purge_config option
b9651a0 Added ability to configure workers for watcher api
13da01d Fix documentation for log_dir parameter
1e3195a Add basic structure for ReNo
d180ed8 Move rspec-puppet-facts to spec helper
e321519 Fix puppet-lint before upgrading gem
531be96 Change authtoken to class
b2d2c60 Added planer sections
72e2a49 Changed api service requirements
11d3887 Implement applier and decision-engine
c5ddc31 Implement watcher-db-manage commands
b30e232 Fix authtoken options and adding the missing
9de450c Include openstacklib defaults manifest.
b7d6b99 Added watcher package ensure
6aaa40c Update metadata
1dc80b3 Implement api.pp
58c20a1 This commit adds the initial project files.
08582df Add nodepool-xenial.yml file
5f405ee Update metadata name
00d4250 Remove default_facts
3aa6c0e Change wiki to docs
812594b puppet-watcher: Initial commit




Requirements updates
--------------------

diff --git a/test-requirements.txt b/test-requirements.txt
new file mode 100644
index 0000000..bedd666
--- /dev/null
+++ b/test-requirements.txt
@@ -0,0 +1,4 @@
+# this is required for the docs build jobs
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
+oslosphinx>=2.5.0 # Apache-2.0
+reno>=0.1.1 # Apache-2.0



_______________________________________________
OpenStack-announce mailing list
[hidden email]
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce