[new][watcher] python-watcherclient 0.26.0 release (ocata)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[new][watcher] python-watcherclient 0.26.0 release (ocata)

no-reply
We are gleeful to announce the release of:

python-watcherclient 0.26.0: Python client library for Watcher API

This release is part of the ocata release series.

The source is available from:

    http://git.openstack.org/cgit/openstack/python-watcher

Download the package from:

    https://pypi.python.org/pypi/python-watcherclient

Please report issues through launchpad:

    http://bugs.launchpad.net/watcher

For more details, please see below.

Changes in python-watcherclient 0.25.0..0.26.0
----------------------------------------------

51b295c Updated from global requirements
c8bf47d Remove obsolete object attributes
c83499e Fix a typo error in a help message in the client
9edd6af Updated from global requirements
9923b51 Remove unnecessary ')'
7dfcdba Add Python 3.5 classifier and venv
dfdee21 Add __ne__ built-in function
494b2ec Updated from global requirements
c185f32 Add support for Audit Scope
466131e Add parameters in Audit creation attributes list
c885514 Updated from global requirements
940a709 Added support for Client creation from KS session
0c0f6cb Updated from global requirements
f50df0d Add fixtures to test-requirements
abf3257 Add constraint target to tox.ini and remove 1 dep
4e86151 Add service support
a48a921 python-openstackclient ClientManager interface changed
ad4ee3f Update home page link in cfg file
4df180f Clean imports in code


Diffstat (except docs and test files)
-------------------------------------

requirements.txt                                   |  13 +-
setup.cfg                                          |   9 +-
test-requirements.txt                              |   7 +-
tox.ini                                            |  11 +-
watcherclient/client.py                            | 258 +++++----
watcherclient/common/api_versioning.py             | 215 +++++++
watcherclient/common/apiclient/base.py             |   5 +-
watcherclient/common/apiclient/exceptions.py       |   4 -
watcherclient/common/command.py                    |   6 +-
watcherclient/common/http.py                       | 388 -------------
watcherclient/common/httpclient.py                 | 632 +++++++++++++++++++++
watcherclient/common/utils.py                      |   9 +
watcherclient/exceptions.py                        |  21 +-
watcherclient/plugin.py                            |  19 +-
watcherclient/shell.py                             | 160 +-----
watcherclient/v1/__init__.py                       |   5 +-
watcherclient/v1/action.py                         |   6 -
watcherclient/v1/action_plan_shell.py              |   9 +-
watcherclient/v1/audit.py                          |   5 +-
watcherclient/v1/audit_shell.py                    |  16 +-
watcherclient/v1/audit_template.py                 |   3 +-
watcherclient/v1/audit_template_shell.py           |  73 ++-
watcherclient/v1/client.py                         |  31 +-
watcherclient/v1/metric_collector.py               | 101 ----
watcherclient/v1/resource_fields.py                |  22 +-
watcherclient/v1/service.py                        |  78 +++
watcherclient/v1/service_shell.py                  | 103 ++++
46 files changed, 2192 insertions(+), 1735 deletions(-)


Requirements updates
--------------------

diff --git a/requirements.txt b/requirements.txt
index f4d068e..da9c4b6 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -6,2 +6,2 @@ Babel>=2.3.4 # BSD
-cliff!=1.16.0,!=1.17.0,>=1.15.0 # Apache-2.0
-osc-lib>=1.0.2 # Apache-2.0
+cliff>=2.2.0 # Apache-2.0
+osc-lib>=1.2.0 # Apache-2.0
@@ -9,4 +9,4 @@ oslo.i18n>=2.1.0 # Apache-2.0
-oslo.utils>=3.16.0 # Apache-2.0
-pbr>=1.6 # Apache-2.0
-PrettyTable<0.8,>=0.7 # BSD
-python-keystoneclient!=2.1.0,>=2.0.0 # Apache-2.0
+oslo.utils>=3.18.0 # Apache-2.0
+pbr>=1.8 # Apache-2.0
+PrettyTable<0.8,>=0.7.1 # BSD
+python-keystoneclient>=3.6.0 # Apache-2.0
@@ -13,0 +14 @@ six>=1.9.0 # MIT
+PyYAML>=3.10.0 # MIT
diff --git a/test-requirements.txt b/test-requirements.txt
index ae3d8f2..24b5276 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -5 +5,2 @@
-coverage>=3.6 # Apache-2.0
+coverage>=4.0 # Apache-2.0
+fixtures>=3.0.0 # Apache-2.0/BSD
@@ -8 +9 @@ mock>=2.0 # BSD
-oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
+oslosphinx>=4.7.0 # Apache-2.0
@@ -11 +12 @@ python-subunit>=0.0.18 # Apache-2.0/BSD
-sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
+sphinx!=1.3b1,<1.4,>=1.2.1 # BSD



_______________________________________________
OpenStack-announce mailing list
[hidden email]
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce