nova-volume installation failed

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

nova-volume installation failed

Shaon
When I try to install nova-volume, it gives me an error with *runit *and as
a consequence *nova-volume* is not running.
*
*Error: http://pastebin.com/hA6bZX4Q

$ sudo apt-get install nova-volume
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  runit vblade-persist
Suggested packages:
  sheepdog socklog-run
The following NEW packages will be installed:
  nova-volume runit vblade-persist
0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/122 kB of archives.
After this operation, 782 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package runit.
(Reading database ... 59125 files and directories currently installed.)
Unpacking runit (from .../runit_2.1.1-6.2ubuntu1_amd64.deb) ...
Selecting previously deselected package vblade-persist.
Unpacking vblade-persist (from .../vblade-persist_0.6-2_all.deb) ...
Selecting previously deselected package nova-volume.
Unpacking nova-volume (from .../nova-volume_2011.2~bzr663-0ubuntu1_all.deb)
...
Processing triggers for ureadahead ...
Processing triggers for man-db ...
Setting up runit (2.1.1-6.2ubuntu1) ...
runsvdir start/running, process 2694
start: Job is already running: runsvdir
dpkg: error processing runit (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of vblade-persist:
 vblade-persist depends on runit (>= 1.8.0-2); however:
  Package runit is not configured yet.
dpkg: error processing vblade-persist (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup
error from a previous failure.

dpkg: dependency problems prevent configuration of nova-volume:
 nova-volume depends on vblade-persist; however:
  Package vblade-persist is not configured yet.
dpkg: error processing nova-volume (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup
error from a previous failure.

Errors were encountered while processing:
 runit
 vblade-persist
 nova-volume
E: Sub-process /usr/bin/dpkg returned an error code (1)


--
thanks
-shaon

http://twitter.com/mdshaonimran
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110726/26dbb5de/attachment.html>

Reply | Threaded
Open this post in threaded view
|

nova-volume installation failed

Shaon
thanks. that problem has been fixed.

On Tue, Jul 26, 2011 at 6:49 PM, Shaon <mdshaonimran at gmail.com> wrote:

> When I try to install nova-volume, it gives me an error with *runit *and
> as a consequence *nova-volume* is not running.
> *
> *Error: http://pastebin.com/hA6bZX4Q
>
> $ sudo apt-get install nova-volume
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
>   runit vblade-persist
> Suggested packages:
>   sheepdog socklog-run
> The following NEW packages will be installed:
>   nova-volume runit vblade-persist
> 0 upgraded, 3 newly installed, 0 to remove and 3 not upgraded.
> Need to get 0 B/122 kB of archives.
> After this operation, 782 kB of additional disk space will be used.
> Do you want to continue [Y/n]? y
> Selecting previously deselected package runit.
> (Reading database ... 59125 files and directories currently installed.)
> Unpacking runit (from .../runit_2.1.1-6.2ubuntu1_amd64.deb) ...
> Selecting previously deselected package vblade-persist.
> Unpacking vblade-persist (from .../vblade-persist_0.6-2_all.deb) ...
> Selecting previously deselected package nova-volume.
> Unpacking nova-volume (from .../nova-volume_2011.2~bzr663-0ubuntu1_all.deb)
> ...
> Processing triggers for ureadahead ...
> Processing triggers for man-db ...
> Setting up runit (2.1.1-6.2ubuntu1) ...
> runsvdir start/running, process 2694
> start: Job is already running: runsvdir
> dpkg: error processing runit (--configure):
>  subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of vblade-persist:
>  vblade-persist depends on runit (>= 1.8.0-2); however:
>   Package runit is not configured yet.
> dpkg: error processing vblade-persist (--configure):
>  dependency problems - leaving unconfigured
> No apport report written because the error message indicates its a followup
> error from a previous failure.
>
> dpkg: dependency problems prevent configuration of nova-volume:
>  nova-volume depends on vblade-persist; however:
>   Package vblade-persist is not configured yet.
> dpkg: error processing nova-volume (--configure):
>  dependency problems - leaving unconfigured
> No apport report written because the error message indicates its a followup
> error from a previous failure.
>
> Errors were encountered while processing:
>  runit
>  vblade-persist
>  nova-volume
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
>
> --
> thanks
> -shaon
>
> http://twitter.com/mdshaonimran
>
>


--
thanks
-shaon

http://mdshaonimran.wordpress.com
http://twitter.com/mdshaonimran
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstack.org/pipermail/openstack-operators/attachments/20110728/b654b054/attachment.html>