[requirements][masakari] FFE for adding python-masakariclient in global-requirements

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[requirements][masakari] FFE for adding python-masakariclient in global-requirements

Bhor, Dinesh

Hello everyone,

 

I would like to ask for the FFE for adding "python-masakariclient" in global-requirements.

 

Earlier, we were not having "check-requirements" job for masakari-* projects. At that time, we use to manually add "python-masakariclient" as a requirement in masakari-monitors project [1].

Now we have added "check-requirements" job for masakari-* projects, but we missed to add "python-masakariclient" in global-requirements and now the bigger issue is it is not possible

to manually update the "python-masakariclient" requirement in masakari-monitors project as the "gate-masakari-monitors-requirements" requirements job keeps failing on the patch [1].

To resolve this problem permanently, we need to add "python-masakariclient" library requirement in global-requirements.

I have submitted a patch [2] for adding the python-masakariclient in global-requirements.

 

Please consider my request and grant FFE to solve this problem.

 

[1] https://review.openstack.org/#/c/457491/

[2] https://review.openstack.org/#/c/491692/

 

 

Thank you,

Dinesh Bhor | App. Software Dev. Cnslt.

[hidden email] | nttdata.com/americas


______________________________________________________________________
Disclaimer: This email and any attachments are sent in strictest confidence
for the sole use of the addressee and may contain legally privileged,
confidential, and proprietary data. If you are not the intended recipient,
please advise the sender by replying promptly to this email and then delete
and destroy this email and any attachments without any further use, copying
or forwarding.

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Thierry Carrez
Bhor, Dinesh wrote:

> I would like to ask for the FFE for adding "*python-masakariclient*" in
> global-requirements.
>
> Earlier, we were not having "check-requirements" job for masakari-*
> projects. At that time, we use to manually add "*python-masakariclient*"
> as a requirement in *masakari-monitors* project [1].
>
> Now we have added "*check-requirements*" job for masakari-* projects,
> but we missed to add "python-masakariclient" in global-requirements and
> now the bigger issue is it is not possible
>
> to *manually update* the "python-masakariclient" requirement in
> masakari-monitors project as the "*gate-masakari-monitors-requirements*"
> requirements job keeps failing on the patch [1].
>
> To resolve this problem permanently, we need to add
> "python-masakariclient" library requirement in global-requirements.
>
> I have submitted a patch [2] for adding the python-masakariclient in
> global-requirements.
>
> Please consider my request and grant FFE to solve this problem.
>
> [1] https://review.openstack.org/#/c/457491/
> [2] https://review.openstack.org/#/c/491692/

It feels like this could wait until we create a stable/pike branch for
the requirements (which will happen as soon as we have RC1 for all
cycle-with-milestones projects, in theory at the end of this week, in
practice probably early next week).

--
Thierry Carrez (ttx)

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Tony Breeds
In reply to this post by Bhor, Dinesh
On Wed, Aug 09, 2017 at 06:39:52AM +0000, Bhor, Dinesh wrote:

> Hello everyone,
>
> I would like to ask for the FFE for adding "python-masakariclient" in global-requirements.
>
> Earlier, we were not having "check-requirements" job for masakari-* projects. At that time, we use to manually add "python-masakariclient" as a requirement in masakari-monitors project [1].
> Now we have added "check-requirements" job for masakari-* projects, but we missed to add "python-masakariclient" in global-requirements and now the bigger issue is it is not possible
> to manually update the "python-masakariclient" requirement in masakari-monitors project as the "gate-masakari-monitors-requirements" requirements job keeps failing on the patch [1].
> To resolve this problem permanently, we need to add "python-masakariclient" library requirement in global-requirements.
> I have submitted a patch [2] for adding the python-masakariclient in global-requirements.
>
> Please consider my request and grant FFE to solve this problem.
>
> [1] https://review.openstack.org/#/c/457491/
> [2] https://review.openstack.org/#/c/491692/
Are you intending to create a stable/pike branch and perform releases
from it?  Looking at masakari-monitors the whole history can be seen on
one page so it's clearly very new.

Yours Tony.

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Bhor, Dinesh
Hi Tony and all,

Sorry for the delay to reply.

We are planning to create the stable/pike branch soon. I am contacting the PTL Sampath Priyankara(samP) for the exact date.

Thanks and Regards,
Dinesh Bhor | App. Software Dev. Cnslt.
[hidden email] | nttdata.com/americas


-----Original Message-----
From: Tony Breeds [mailto:[hidden email]]
Sent: Wednesday, August 09, 2017 5:25 PM
To: OpenStack Development Mailing List (not for usage questions)
Subject: Re: [openstack-dev] [requirements][masakari] FFE for adding python-masakariclient in global-requirements

On Wed, Aug 09, 2017 at 06:39:52AM +0000, Bhor, Dinesh wrote:

> Hello everyone,
>
> I would like to ask for the FFE for adding "python-masakariclient" in global-requirements.
>
> Earlier, we were not having "check-requirements" job for masakari-* projects. At that time, we use to manually add "python-masakariclient" as a requirement in masakari-monitors project [1].
> Now we have added "check-requirements" job for masakari-* projects,
> but we missed to add "python-masakariclient" in global-requirements and now the bigger issue is it is not possible to manually update the "python-masakariclient" requirement in masakari-monitors project as the "gate-masakari-monitors-requirements" requirements job keeps failing on the patch [1].
> To resolve this problem permanently, we need to add "python-masakariclient" library requirement in global-requirements.
> I have submitted a patch [2] for adding the python-masakariclient in global-requirements.
>
> Please consider my request and grant FFE to solve this problem.
>
> [1] https://review.openstack.org/#/c/457491/
> [2] https://review.openstack.org/#/c/491692/

Are you intending to create a stable/pike branch and perform releases from it?  Looking at masakari-monitors the whole history can be seen on one page so it's clearly very new.

Yours Tony.

______________________________________________________________________
Disclaimer: This email and any attachments are sent in strictest confidence
for the sole use of the addressee and may contain legally privileged,
confidential, and proprietary data. If you are not the intended recipient,
please advise the sender by replying promptly to this email and then delete
and destroy this email and any attachments without any further use, copying
or forwarding.
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Sam P
Hi Tony,

For maskari-monitors, earliest we can cut stable/pike is 8/11.
You was mentioned about masakari and related projects in [1].
For python-masakariclient, stable/pike can be cut on 8/11.
However, for maskari I would like to land few changes before cut stable/pike and
hopefully we can cut stable/pike after 8/15 masakari team meeting.

  As I discussed with Matthew[2], In the case, you unfreeze
requirements before 8/15,
 we can block requirements update for masakari till we create the
stable/pike branch.
 Any comments on this plan?

> Looking at masakari-monitors the whole history can be seen on one page so it's clearly very new.
I created it 10 months ago. Original code can be found in [3]. We
split [3] into masakari and masakari-monitors and
did lot of enhancements.


[1] http://lists.openstack.org/pipermail/openstack-dev/2017-August/120922.html
[2] http://eavesdrop.openstack.org/irclogs/%23openstack-requirements/%23openstack-requirements.2017-08-10.log.html#t2017-08-10T17:11:42
[3] https://github.com/ntt-sic/masakari
--- Regards,
Sampath



On Thu, Aug 10, 2017 at 1:23 AM, Bhor, Dinesh <[hidden email]> wrote:

> Hi Tony and all,
>
> Sorry for the delay to reply.
>
> We are planning to create the stable/pike branch soon. I am contacting the PTL Sampath Priyankara(samP) for the exact date.
>
> Thanks and Regards,
> Dinesh Bhor | App. Software Dev. Cnslt.
> [hidden email] | nttdata.com/americas
>
>
> -----Original Message-----
> From: Tony Breeds [mailto:[hidden email]]
> Sent: Wednesday, August 09, 2017 5:25 PM
> To: OpenStack Development Mailing List (not for usage questions)
> Subject: Re: [openstack-dev] [requirements][masakari] FFE for adding python-masakariclient in global-requirements
>
> On Wed, Aug 09, 2017 at 06:39:52AM +0000, Bhor, Dinesh wrote:
>> Hello everyone,
>>
>> I would like to ask for the FFE for adding "python-masakariclient" in global-requirements.
>>
>> Earlier, we were not having "check-requirements" job for masakari-* projects. At that time, we use to manually add "python-masakariclient" as a requirement in masakari-monitors project [1].
>> Now we have added "check-requirements" job for masakari-* projects,
>> but we missed to add "python-masakariclient" in global-requirements and now the bigger issue is it is not possible to manually update the "python-masakariclient" requirement in masakari-monitors project as the "gate-masakari-monitors-requirements" requirements job keeps failing on the patch [1].
>> To resolve this problem permanently, we need to add "python-masakariclient" library requirement in global-requirements.
>> I have submitted a patch [2] for adding the python-masakariclient in global-requirements.
>>
>> Please consider my request and grant FFE to solve this problem.
>>
>> [1] https://review.openstack.org/#/c/457491/
>> [2] https://review.openstack.org/#/c/491692/
>
> Are you intending to create a stable/pike branch and perform releases from it?  Looking at masakari-monitors the whole history can be seen on one page so it's clearly very new.
>
> Yours Tony.
>
> ______________________________________________________________________
> Disclaimer: This email and any attachments are sent in strictest confidence
> for the sole use of the addressee and may contain legally privileged,
> confidential, and proprietary data. If you are not the intended recipient,
> please advise the sender by replying promptly to this email and then delete
> and destroy this email and any attachments without any further use, copying
> or forwarding.
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: [hidden email]?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Tony Breeds
On Thu, Aug 10, 2017 at 12:58:21PM -0500, Sam P wrote:

> Hi Tony,
>
> For maskari-monitors, earliest we can cut stable/pike is 8/11.
> You was mentioned about masakari and related projects in [1].
> For python-masakariclient, stable/pike can be cut on 8/11.
> However, for maskari I would like to land few changes before cut stable/pike and
> hopefully we can cut stable/pike after 8/15 masakari team meeting.
>
>   As I discussed with Matthew[2], In the case, you unfreeze
> requirements before 8/15,
>  we can block requirements update for masakari till we create the
> stable/pike branch.
>  Any comments on this plan?
Based on what you've said Masakari is going to have a stable/pike
branch.  So we have 3 options:

1) Grant the FFE and ensure that the bot-generated change lands in
   masakari-monitors before they branch ; or

2) Wait until after both requirements and masakari branch and takes this
   on master backport it to pike (which would kinda sorta be a process
   violation) and then let the bot take over ; or

3) Just take this on master and disable the check-requirements for
   masakari on stable/*

It seems to me that option 1 is the least work and ends up with the best
result.

So with that in mind I'm going to approve:
    https://review.openstack.org/#/c/491692/

Once that merges the bot will suggest a review to update your
requirements files.

You can take that or:
    https://review.openstack.org/#/c/457491/

or some combination of both after resolving any merge conflicts.

You'll need to do one of those before you branch stable/pike

Apart from the change described above you're right.  You need to block
and changes generated by the proposal bot from the time requirements
branches until you branch.

All good?

Yours Tony.

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Sam P
Hi Tony,

 As you suggested, I would like go with option 1.

> Once that merges the bot will suggest a review to update your
> requirements files.
>
> You can take that or:
>     https://review.openstack.org/#/c/457491/
Thanks for the update and I will try to merge #/c/457491 asap.
Otherwise I will resolve the merge conflicts.

> Apart from the change described above you're right.  You need to block
> and changes generated by the proposal bot from the time requirements
> branches until you branch.
> All good?
All good.  Thank you for all the help and support..


--- Regards,
Sampath



On Thu, Aug 10, 2017 at 7:08 PM, Tony Breeds <[hidden email]> wrote:

> On Thu, Aug 10, 2017 at 12:58:21PM -0500, Sam P wrote:
>> Hi Tony,
>>
>> For maskari-monitors, earliest we can cut stable/pike is 8/11.
>> You was mentioned about masakari and related projects in [1].
>> For python-masakariclient, stable/pike can be cut on 8/11.
>> However, for maskari I would like to land few changes before cut stable/pike and
>> hopefully we can cut stable/pike after 8/15 masakari team meeting.
>>
>>   As I discussed with Matthew[2], In the case, you unfreeze
>> requirements before 8/15,
>>  we can block requirements update for masakari till we create the
>> stable/pike branch.
>>  Any comments on this plan?
>
> Based on what you've said Masakari is going to have a stable/pike
> branch.  So we have 3 options:
>
> 1) Grant the FFE and ensure that the bot-generated change lands in
>    masakari-monitors before they branch ; or
>
> 2) Wait until after both requirements and masakari branch and takes this
>    on master backport it to pike (which would kinda sorta be a process
>    violation) and then let the bot take over ; or
>
> 3) Just take this on master and disable the check-requirements for
>    masakari on stable/*
>
> It seems to me that option 1 is the least work and ends up with the best
> result.
>
> So with that in mind I'm going to approve:
>     https://review.openstack.org/#/c/491692/
>
> Once that merges the bot will suggest a review to update your
> requirements files.
>
> You can take that or:
>     https://review.openstack.org/#/c/457491/
>
> or some combination of both after resolving any merge conflicts.
>
> You'll need to do one of those before you branch stable/pike
>
> Apart from the change described above you're right.  You need to block
> and changes generated by the proposal bot from the time requirements
> branches until you branch.
>
> All good?
>
> Yours Tony.
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: [hidden email]?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Sam P
Hi Tony,

Correction:
>> You can take that or:
>>     https://review.openstack.org/#/c/457491/
> Thanks for the update and I will try to merge #/c/457491 asap.
> Otherwise I will resolve the merge conflicts.
I did not realize that you add [1] depends on [2]. I will wait for [2]
to get merged.

[1] https://review.openstack.org/#/c/457491
[2] https://review.openstack.org/#/c/491692/
--- Regards,
Sampath



On Thu, Aug 10, 2017 at 11:59 PM, Sam P <[hidden email]> wrote:

> Hi Tony,
>
>  As you suggested, I would like go with option 1.
>
>> Once that merges the bot will suggest a review to update your
>> requirements files.
>>
>> You can take that or:
>>     https://review.openstack.org/#/c/457491/
> Thanks for the update and I will try to merge #/c/457491 asap.
> Otherwise I will resolve the merge conflicts.
>
>> Apart from the change described above you're right.  You need to block
>> and changes generated by the proposal bot from the time requirements
>> branches until you branch.
>> All good?
> All good.  Thank you for all the help and support..
>
>
> --- Regards,
> Sampath
>
>
>
> On Thu, Aug 10, 2017 at 7:08 PM, Tony Breeds <[hidden email]> wrote:
>> On Thu, Aug 10, 2017 at 12:58:21PM -0500, Sam P wrote:
>>> Hi Tony,
>>>
>>> For maskari-monitors, earliest we can cut stable/pike is 8/11.
>>> You was mentioned about masakari and related projects in [1].
>>> For python-masakariclient, stable/pike can be cut on 8/11.
>>> However, for maskari I would like to land few changes before cut stable/pike and
>>> hopefully we can cut stable/pike after 8/15 masakari team meeting.
>>>
>>>   As I discussed with Matthew[2], In the case, you unfreeze
>>> requirements before 8/15,
>>>  we can block requirements update for masakari till we create the
>>> stable/pike branch.
>>>  Any comments on this plan?
>>
>> Based on what you've said Masakari is going to have a stable/pike
>> branch.  So we have 3 options:
>>
>> 1) Grant the FFE and ensure that the bot-generated change lands in
>>    masakari-monitors before they branch ; or
>>
>> 2) Wait until after both requirements and masakari branch and takes this
>>    on master backport it to pike (which would kinda sorta be a process
>>    violation) and then let the bot take over ; or
>>
>> 3) Just take this on master and disable the check-requirements for
>>    masakari on stable/*
>>
>> It seems to me that option 1 is the least work and ends up with the best
>> result.
>>
>> So with that in mind I'm going to approve:
>>     https://review.openstack.org/#/c/491692/
>>
>> Once that merges the bot will suggest a review to update your
>> requirements files.
>>
>> You can take that or:
>>     https://review.openstack.org/#/c/457491/
>>
>> or some combination of both after resolving any merge conflicts.
>>
>> You'll need to do one of those before you branch stable/pike
>>
>> Apart from the change described above you're right.  You need to block
>> and changes generated by the proposal bot from the time requirements
>> branches until you branch.
>>
>> All good?
>>
>> Yours Tony.
>>
>> __________________________________________________________________________
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe: [hidden email]?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Tony Breeds
On Fri, Aug 11, 2017 at 12:23:12AM -0500, Sam P wrote:
> Hi Tony,
>
> Correction:
> >> You can take that or:
> >>     https://review.openstack.org/#/c/457491/
> > Thanks for the update and I will try to merge #/c/457491 asap.
> > Otherwise I will resolve the merge conflicts.
> I did not realize that you add [1] depends on [2]. I will wait for [2]
> to get merged.

Okay that's all done.  Please:
- Abandon: https://review.openstack.org/457491
- Merge  : https://review.openstack.org/492965

Then you're good to go :)

Yours Tony.

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

signature.asc (499 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [requirements][masakari] FFE for adding python-masakariclient in global-requirements

Sam P
Hi Tony,
 Thanks.
> - Abandon: https://review.openstack.org/457491
> - Merge  : https://review.openstack.org/492965
Done.

--- Regards,
Sampath



On Sat, Aug 12, 2017 at 8:13 AM, Tony Breeds <[hidden email]> wrote:

> On Fri, Aug 11, 2017 at 12:23:12AM -0500, Sam P wrote:
>> Hi Tony,
>>
>> Correction:
>> >> You can take that or:
>> >>     https://review.openstack.org/#/c/457491/
>> > Thanks for the update and I will try to merge #/c/457491 asap.
>> > Otherwise I will resolve the merge conflicts.
>> I did not realize that you add [1] depends on [2]. I will wait for [2]
>> to get merged.
>
> Okay that's all done.  Please:
> - Abandon: https://review.openstack.org/457491
> - Merge  : https://review.openstack.org/492965
>
> Then you're good to go :)
>
> Yours Tony.
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: [hidden email]?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: [hidden email]?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
Loading...